Re: [Pharo-project] I don't agree with DummyXXX
I totally agree. Dummy does not tell me about the class. Are there just 3 uses of Dummy in the core? We should either use Null or use a specific prefix always, so its form a consisten pattern. DummyUIManager -> NullUIManager Fernando On Wed, Nov 21, 2012 at 4:34 PM, Mariano Martinez Peck < marianopeck@gmail.com> wrote:
From what I understand, Dummy means something different. I have using that for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
-- Mariano http://marianopeck.wordpress.com
On 21 November 2012 12:47, Fernando Olivero <fernando.olivero@usi.ch> wrote:
I totally agree. Dummy does not tell me about the class.
Are there just 3 uses of Dummy in the core?
We should either use Null or use a specific prefix always, so its form a consisten pattern.
DummyUIManager -> NullUIManager
yes, not "Headless" please.
Fernando
On Wed, Nov 21, 2012 at 4:34 PM, Mariano Martinez Peck <marianopeck@gmail.com> wrote:
From what I understand, Dummy means something different. I have using that for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
-- Mariano http://marianopeck.wordpress.com
-- Best regards, Igor Stasenko.
On Wed, Nov 21, 2012 at 4:50 PM, Igor Stasenko <siguctua@gmail.com> wrote:
On 21 November 2012 12:47, Fernando Olivero <fernando.olivero@usi.ch> wrote:
I totally agree. Dummy does not tell me about the class.
Are there just 3 uses of Dummy in the core?
We should either use Null or use a specific prefix always, so its form a consisten pattern.
DummyUIManager -> NullUIManager
yes, not "Headless" please.
why? It is not a complete NULL UIManager. A NullUIManager would implement all the API and do nothing (or implement nothing but only #doesNotUnderstand: doing nothing or something like that) DummyUIManger DOES stuff, but it makes sures not to end up calling the UI (like progress bar, notifications, confirmations, etc). So, in this particular case, HeadlessUIManager is much more accurate for me than Null.
Fernando
On Wed, Nov 21, 2012 at 4:34 PM, Mariano Martinez Peck <marianopeck@gmail.com> wrote:
From what I understand, Dummy means something different. I have using
that
for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
-- Mariano http://marianopeck.wordpress.com
-- Best regards, Igor Stasenko.
-- Mariano http://marianopeck.wordpress.com
On 21 November 2012 14:55, Mariano Martinez Peck <marianopeck@gmail.com> wrote:
On Wed, Nov 21, 2012 at 4:50 PM, Igor Stasenko <siguctua@gmail.com> wrote:
On 21 November 2012 12:47, Fernando Olivero <fernando.olivero@usi.ch> wrote:
I totally agree. Dummy does not tell me about the class.
Are there just 3 uses of Dummy in the core?
We should either use Null or use a specific prefix always, so its form a consisten pattern.
DummyUIManager -> NullUIManager
yes, not "Headless" please.
why?
It is not a complete NULL UIManager. A NullUIManager would implement all the API and do nothing (or implement nothing but only #doesNotUnderstand: doing nothing or something like that) DummyUIManger DOES stuff, but it makes sures not to end up calling the UI (like progress bar, notifications, confirmations, etc). So, in this particular case, HeadlessUIManager is much more accurate for me than Null.
then you will need to explain EVERY time to users why they should use CommandLineUIManager, or NonInteractiveUIManager for headless mode, rather than HeadlessUIManager. Good luck with that :)
Fernando
On Wed, Nov 21, 2012 at 4:34 PM, Mariano Martinez Peck <marianopeck@gmail.com> wrote:
From what I understand, Dummy means something different. I have using that for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
-- Mariano http://marianopeck.wordpress.com
-- Best regards, Igor Stasenko.
-- Mariano http://marianopeck.wordpress.com
-- Best regards, Igor Stasenko.
On 21 November 2012 15:11, Igor Stasenko <siguctua@gmail.com> wrote:
On 21 November 2012 14:55, Mariano Martinez Peck <marianopeck@gmail.com> wrote:
On Wed, Nov 21, 2012 at 4:50 PM, Igor Stasenko <siguctua@gmail.com> wrote:
On 21 November 2012 12:47, Fernando Olivero <fernando.olivero@usi.ch> wrote:
I totally agree. Dummy does not tell me about the class.
Are there just 3 uses of Dummy in the core?
We should either use Null or use a specific prefix always, so its form a consisten pattern.
DummyUIManager -> NullUIManager
yes, not "Headless" please.
why?
It is not a complete NULL UIManager. A NullUIManager would implement all the API and do nothing (or implement nothing but only #doesNotUnderstand: doing nothing or something like that) DummyUIManger DOES stuff, but it makes sures not to end up calling the UI (like progress bar, notifications, confirmations, etc). So, in this particular case, HeadlessUIManager is much more accurate for me than Null.
then you will need to explain EVERY time to users why they should use CommandLineUIManager, or NonInteractiveUIManager for headless mode, rather than HeadlessUIManager. Good luck with that :)
this is, btw , one of the reasons why i picked NonInteractive name instead of calling it 'headless'. Because it is more precise. And Camillo also used 'CommandLine' instead of 'Headless'. In this regard, Dummy/Null is much more precise with describing behavior of that ui manager class than headless. -- Best regards, Igor Stasenko.
be careful with precision vs. intuition conventions each of them have benefits for the long and short term also a price On Nov 21, 2012, at 4:14 PM, Igor Stasenko wrote:
On 21 November 2012 15:11, Igor Stasenko <siguctua@gmail.com> wrote:
On 21 November 2012 14:55, Mariano Martinez Peck <marianopeck@gmail.com> wrote:
On Wed, Nov 21, 2012 at 4:50 PM, Igor Stasenko <siguctua@gmail.com> wrote:
On 21 November 2012 12:47, Fernando Olivero <fernando.olivero@usi.ch> wrote:
I totally agree. Dummy does not tell me about the class.
Are there just 3 uses of Dummy in the core?
We should either use Null or use a specific prefix always, so its form a consisten pattern.
DummyUIManager -> NullUIManager
yes, not "Headless" please.
why?
It is not a complete NULL UIManager. A NullUIManager would implement all the API and do nothing (or implement nothing but only #doesNotUnderstand: doing nothing or something like that) DummyUIManger DOES stuff, but it makes sures not to end up calling the UI (like progress bar, notifications, confirmations, etc). So, in this particular case, HeadlessUIManager is much more accurate for me than Null.
then you will need to explain EVERY time to users why they should use CommandLineUIManager, or NonInteractiveUIManager for headless mode, rather than HeadlessUIManager. Good luck with that :)
this is, btw , one of the reasons why i picked NonInteractive name instead of calling it 'headless'. Because it is more precise. And Camillo also used 'CommandLine' instead of 'Headless'.
In this regard, Dummy/Null is much more precise with describing behavior of that ui manager class than headless.
-- Best regards, Igor Stasenko.
why?
It is not a complete NULL UIManager. A NullUIManager would implement all the API and do nothing (or implement nothing but only #doesNotUnderstand: doing nothing or something like that) DummyUIManger DOES stuff, but it makes sures not to end up calling the UI (like progress bar, notifications, confirmations, etc). So, in this particular case, HeadlessUIManager is much more accurate for me than Null.
then you will need to explain EVERY time to users why they should use CommandLineUIManager, or NonInteractiveUIManager for headless mode, rather than HeadlessUIManager. Good luck with that :)
this is, btw , one of the reasons why i picked NonInteractive name instead of calling it 'headless'. Because it is more precise. And Camillo also used 'CommandLine' instead of 'Headless'.
In this regard, Dummy/Null is much more precise with describing behavior of that ui manager class than headless.
exactly! :)
What about "SilentXXX"? 2012/11/21 Camillo Bruni <camillobruni@gmail.com>:
why?
It is not a complete NULL UIManager. A NullUIManager would implement all the API and do nothing (or implement nothing but only #doesNotUnderstand: doing nothing or something like that) DummyUIManger DOES stuff, but it makes sures not to end up calling the UI (like progress bar, notifications, confirmations, etc). So, in this particular case, HeadlessUIManager is much more accurate for me than Null.
then you will need to explain EVERY time to users why they should use CommandLineUIManager, or NonInteractiveUIManager for headless mode, rather than HeadlessUIManager. Good luck with that :)
this is, btw , one of the reasons why i picked NonInteractive name instead of calling it 'headless'. Because it is more precise. And Camillo also used 'CommandLine' instead of 'Headless'.
In this regard, Dummy/Null is much more precise with describing behavior of that ui manager class than headless.
exactly! :)
On 21.11.2012 18:55, Mariano Martinez Peck wrote:
On Wed, Nov 21, 2012 at 4:50 PM, Igor Stasenko <siguctua@gmail.com <mailto:siguctua@gmail.com>> wrote:
On 21 November 2012 12:47, Fernando Olivero <fernando.olivero@usi.ch <mailto:fernando.olivero@usi.ch>> wrote: > I totally agree. Dummy does not tell me about the class. > > Are there just 3 uses of Dummy in the core? > > We should either use Null or use a specific prefix always, so its form a > consisten pattern. > > DummyUIManager -> NullUIManager > yes, not "Headless" please.
why?
It is not a complete NULL UIManager. A NullUIManager would implement all the API and do nothing (or implement nothing but only #doesNotUnderstand: doing nothing or something like that) DummyUIManger DOES stuff, but it makes sures not to end up calling the UI (like progress bar, notifications, confirmations, etc). So, in this particular case, HeadlessUIManager is much more accurate for me than Null.
Same can be said for DummySoundSystem, it does route the Beeper sound to a tangible place. ;) How about MinimalXXX? As in, they do the least amount of things possible to still remain useful in a limited, yet non-null manner. Cheers, Henry
On Wed, Nov 21, 2012 at 4:47 PM, Fernando Olivero <fernando.olivero@usi.ch>wrote:
I totally agree. Dummy does not tell me about the class.
Are there just 3 uses of Dummy in the core?
there are some other about Spec but I don't know what they do.
We should either use Null or use a specific prefix always, so its form a consisten pattern.
+1
DummyUIManager -> NullUIManager
But it is not a complete NULL UIManager. It does stuff, but it makes sures not to end up calling the UI (like progress bar, notifications, confirmations, etc). So, in this particular case, HeadlessUIManager is much more accurate for me than Null. In the others, Null is the most accurate for me.
Fernando
On Wed, Nov 21, 2012 at 4:34 PM, Mariano Martinez Peck < marianopeck@gmail.com> wrote:
From what I understand, Dummy means something different. I have using that for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
-- Mariano http://marianopeck.wordpress.com
-- Mariano http://marianopeck.wordpress.com
Nicht um 1600 Uhr ? Wolltest Du nicht noch Unterlagen rumschicken ? marten On 21.11.2012 16:47, Fernando Olivero wrote:
I totally agree. Dummy does not tell me about the class.
Are there just 3 uses of Dummy in the core?
We should either use Null or use a specific prefix always, so its form a consisten pattern.
DummyUIManager -> NullUIManager
Fernando
On Wed, Nov 21, 2012 at 4:34 PM, Mariano Martinez Peck <marianopeck@gmail.com <mailto:marianopeck@gmail.com>> wrote:
From what I understand, Dummy means something different. I have using that for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
-- Mariano http://marianopeck.wordpress.com
DeafX Deaf suggesting "an X that's non reactive as you would normally expect" On Nov 21, 2012, at 1:47 PM, Fernando Olivero wrote:
I totally agree. Dummy does not tell me about the class.
Are there just 3 uses of Dummy in the core?
We should either use Null or use a specific prefix always, so its form a consisten pattern.
DummyUIManager -> NullUIManager
Fernando
On Wed, Nov 21, 2012 at 4:34 PM, Mariano Martinez Peck <marianopeck@gmail.com> wrote: From what I understand, Dummy means something different. I have using that for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
-- Mariano http://marianopeck.wordpress.com
How about "void" or "noon"? On 21.11.2012, at 17:07, Sebastian Sastre <sebastian@flowingconcept.com> wrote:
DeafX
Deaf suggesting "an X that's non reactive as you would normally expect"
On Nov 21, 2012, at 1:47 PM, Fernando Olivero wrote:
I totally agree. Dummy does not tell me about the class.
Are there just 3 uses of Dummy in the core?
We should either use Null or use a specific prefix always, so its form a consisten pattern.
DummyUIManager -> NullUIManager
Fernando
On Wed, Nov 21, 2012 at 4:34 PM, Mariano Martinez Peck <marianopeck@gmail.com> wrote: From what I understand, Dummy means something different. I have using that for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
-- Mariano http://marianopeck.wordpress.com
I vote for Null* For me Deaf* reminds me the DeafObject of Dolphin which always returns itself (or true to #mustBeBoolean). It is some kind of /dev/null, useful to the creation of the GUI, where some objects aren't available yet and might get an undesired message. Regards! -- View this message in context: http://forum.world.st/I-don-t-agree-with-DummyXXX-tp4656199p4656255.html Sent from the Pharo Smalltalk mailing list archive at Nabble.com.
participants (10)
-
Camillo Bruni -
Esteban A. Maringolo -
Fernando Olivero -
Henrik Sperre Johansen -
Igor Stasenko -
Mariano Martinez Peck -
Marten Feldtmann -
Max Leske -
Sebastian Nozzi -
Sebastian Sastre