On 21 November 2012 12:47, Fernando Olivero <fernando.olivero@usi.ch> wrote:
I totally agree. Dummy does not tell me about the class.
Are there just 3 uses of Dummy in the core?
We should either use Null or use a specific prefix always, so its form a consisten pattern.
DummyUIManager -> NullUIManager
yes, not "Headless" please.
Fernando
On Wed, Nov 21, 2012 at 4:34 PM, Mariano Martinez Peck <marianopeck@gmail.com> wrote:
From what I understand, Dummy means something different. I have using that for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
-- Mariano http://marianopeck.wordpress.com
-- Best regards, Igor Stasenko.