I totally agree.��Dummy does not tell me about the class.
From what I understand, Dummy means something different. I have using that for class names. More accurate names can be found.
I would rename:
DummyUIManager -> HeadlessUIManager
DummySystemProgressItem -> NullSystemProgressItem
DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
--
Mariano
http://marianopeck.wordpress.com