On Wed, Nov 21, 2012 at 4:50 PM, Igor Stasenko <siguctua@gmail.com> wrote:
On 21 November 2012 12:47, Fernando Olivero <fernando.olivero@usi.ch> wrote:
I totally agree. Dummy does not tell me about the class.
Are there just 3 uses of Dummy in the core?
We should either use Null or use a specific prefix always, so its form a consisten pattern.
DummyUIManager -> NullUIManager
yes, not "Headless" please.
why? It is not a complete NULL UIManager. A NullUIManager would implement all the API and do nothing (or implement nothing but only #doesNotUnderstand: doing nothing or something like that) DummyUIManger DOES stuff, but it makes sures not to end up calling the UI (like progress bar, notifications, confirmations, etc). So, in this particular case, HeadlessUIManager is much more accurate for me than Null.
Fernando
On Wed, Nov 21, 2012 at 4:34 PM, Mariano Martinez Peck <marianopeck@gmail.com> wrote:
From what I understand, Dummy means something different. I have using
that
for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
-- Mariano http://marianopeck.wordpress.com
-- Best regards, Igor Stasenko.
-- Mariano http://marianopeck.wordpress.com