[Pharo-project] class API question
We are not consistent: do we want renameInstVar:to: or removeInstVarName: I prefer that. We have addInstVarName: -> should be addInstVarNamed: from my taste Now we want to have first class instance variable in the near future so I would like to have addInstVar: aVariable addInstVarNamed: aString What do you think? Stef
On Aug 27, 2010, at 11:02 AM, Stéphane Ducasse wrote:
We are not consistent:
do we want renameInstVar:to: or removeInstVarName: I prefer that.
We have addInstVarName: -> should be addInstVarNamed: from my taste
Now we want to have first class instance variable in the near future so I would like to have
addInstVar: aVariable addInstVarNamed: aString
What do you think?
Yes! -- Marcus Denker -- http://www.marcusdenker.de INRIA Lille -- Nord Europe. Team RMoD.
done :) I could not let that like that. Stef On Aug 27, 2010, at 11:11 AM, Marcus Denker wrote:
On Aug 27, 2010, at 11:02 AM, Stéphane Ducasse wrote:
We are not consistent:
do we want renameInstVar:to: or removeInstVarName: I prefer that.
We have addInstVarName: -> should be addInstVarNamed: from my taste
Now we want to have first class instance variable in the near future so I would like to have
addInstVar: aVariable addInstVarNamed: aString
What do you think?
Yes!
-- Marcus Denker -- http://www.marcusdenker.de INRIA Lille -- Nord Europe. Team RMoD.
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
I think it would be beneficial to adapt the protocol of the refactoring browser. It especially spells out all the names: #addInstanceVariable: #allInstanceVariableNames #instanceVariableNames Lukas On 27 August 2010 11:50, Stéphane Ducasse <stephane.ducasse@inria.fr> wrote:
done :) I could not let that like that.
Stef
On Aug 27, 2010, at 11:11 AM, Marcus Denker wrote:
On Aug 27, 2010, at 11:02 AM, Stéphane Ducasse wrote:
We are not consistent:
   do we want        renameInstVar:to:    or        removeInstVarName:            I prefer that.
We have addInstVarName: Â Â Â -> should be addInstVarNamed: from my taste
Now we want to have first class instance variable in the near future so I would like to have
   addInstVar: aVariable    addInstVarNamed: aString
What do you think?
Yes!
-- Marcus Denker  -- http://www.marcusdenker.de INRIA Lille -- Nord Europe. Team RMoD.
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
-- Lukas Renggli www.lukas-renggli.ch
Yep, It would be much better to sell out the names. On Fri, Aug 27, 2010 at 11:53 AM, Lukas Renggli <renggli@gmail.com> wrote:
I think it would be beneficial to adapt the protocol of the refactoring browser.
It especially spells out all the names:
  #addInstanceVariable:   #allInstanceVariableNames   #instanceVariableNames
Lukas
On 27 August 2010 11:50, Stéphane Ducasse <stephane.ducasse@inria.fr> wrote:
done :) I could not let that like that.
Stef
On Aug 27, 2010, at 11:11 AM, Marcus Denker wrote:
On Aug 27, 2010, at 11:02 AM, Stéphane Ducasse wrote:
We are not consistent:
   do we want        renameInstVar:to:    or        removeInstVarName:            I prefer that.
We have addInstVarName: Â Â Â -> should be addInstVarNamed: from my taste
Now we want to have first class instance variable in the near future so I would like to have
   addInstVar: aVariable    addInstVarNamed: aString
What do you think?
Yes!
-- Marcus Denker  -- http://www.marcusdenker.de INRIA Lille -- Nord Europe. Team RMoD.
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
-- Lukas Renggli www.lukas-renggli.ch
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
-- Jorge Ressia www.jorgeressia.com
I think it would be beneficial to adapt the protocol of the refactoring browser.
It especially spells out all the names:
#addInstanceVariable: #allInstanceVariableNames #instanceVariableNames
Lukas
I thought about it too but since we will add first class instances variables then I preferred to use named: for now and like that we can have both interfaces in the future for compatibility. Stef
participants (4)
-
Jorge Ressia -
Lukas Renggli -
Marcus Denker -
Stéphane Ducasse