[Pharo-project] Bug PackageInfo >> classes return also Traits
Hi folks. I've just discovered that PackageInfo >> classes return a collection of classes AND traits. This is incorrect. Solutions are: 1) Rename #classes to #classesAndTraits 2) Modify #classes so that it ONLY answer classes I would like to fix it but I am not sure the consequences of such change. Maybe Monticello doesn't take into account Traits anymore hahha Thanks for any help you can give. Mariano
Hi folks. I've just discovered that PackageInfo >> classes return a collection of classes AND traits. This is incorrect.
Why is this wrong? Collections are mostly polymorphic to traits.
Solutions are:
1) Rename #classes to #classesAndTraits 2) Modify #classes so that it ONLY answer classes
I would like to fix it but I am not sure the consequences of such change. Maybe Monticello doesn't take into account Traits anymore hahha
Yes, all users of PackageInfo will break. Lukas -- Lukas Renggli www.lukas-renggli.ch
Hi folks. I've just discovered that PackageInfo >> classes return a collection of classes AND traits. This is incorrect.
Why is this wrong? Collections are mostly polymorphic to traits.
Ehh, classes are mostly polymorphic to traits. Lukas
Solutions are:
1) Rename #classes to #classesAndTraits 2) Modify #classes so that it ONLY answer classes
I would like to fix it but I am not sure the consequences of such change. Maybe Monticello doesn't take into account Traits anymore hahha
Yes, all users of PackageInfo will break.
Lukas
-- Lukas Renggli www.lukas-renggli.ch
-- Lukas Renggli www.lukas-renggli.ch
On Mon, May 10, 2010 at 11:18 AM, Lukas Renggli <renggli@gmail.com> wrote:
Hi folks. I've just discovered that PackageInfo >> classes return a collection of classes AND traits. This is incorrect.
Why is this wrong? Collections are mostly polymorphic to traits.
I think they are not the same. Even if they are "mostly" polymorphic they are different things. They are not classes. If I ask classes, I want classes. Otherwise I will ask classesAndTraits or just behaviors, but not classes. That's why there are #allClasses, #allClassesAndTraits, #allBehaviorsDo: etc In addition, it is not uniform. It is confusing having places where you have #allClassesAndTraits (here you understand the allClasses doesn't take into account traits) and then you PackageInfo >> classes that answer all the classes but also traits. Cheers Mariano
Solutions are:
1) Rename #classes to #classesAndTraits 2) Modify #classes so that it ONLY answer classes
I would like to fix it but I am not sure the consequences of such change. Maybe Monticello doesn't take into account Traits anymore hahha
Yes, all users of PackageInfo will break.
Lukas
-- Lukas Renggli www.lukas-renggli.ch
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
not for 1.1 guy. it worked so far.... so let us finish 1.1 On May 10, 2010, at 11:15 AM, Mariano Martinez Peck wrote:
Hi folks. I've just discovered that PackageInfo >> classes return a collection of classes AND traits. This is incorrect. Solutions are:
1) Rename #classes to #classesAndTraits 2) Modify #classes so that it ONLY answer classes
I would like to fix it but I am not sure the consequences of such change. Maybe Monticello doesn't take into account Traits anymore hahha
Thanks for any help you can give.
Mariano _______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
On Mon, May 10, 2010 at 1:06 PM, Stéphane Ducasse <stephane.ducasse@inria.fr
wrote:
not for 1.1 guy. it worked so far.... so let us finish 1.1
Ok, I agree. I never said to include it in 1.1. I want just to discuss about it.
On May 10, 2010, at 11:15 AM, Mariano Martinez Peck wrote:
Hi folks. I've just discovered that PackageInfo >> classes return a collection of classes AND traits. This is incorrect. Solutions are:
1) Rename #classes to #classesAndTraits 2) Modify #classes so that it ONLY answer classes
I would like to fix it but I am not sure the consequences of such change. Maybe Monticello doesn't take into account Traits anymore hahha
Thanks for any help you can give.
Mariano _______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
2010/5/10 Mariano Martinez Peck <marianopeck@gmail.com>:
On Mon, May 10, 2010 at 1:06 PM, Stéphane Ducasse <stephane.ducasse@inria.fr> wrote:
not for 1.1 guy. it worked so far.... so let us finish 1.1
Ok, I agree. I never said to include it in 1.1. I want just to discuss about it.
2c I think , right question is to ask, why PackageInfo should even bother to answer this message. Right now , we having a classes and traits. Now suppose, that in some distant future, we might want to add another kind of behavior/data grouping into a package. So, should we then implement PackageInfo >>classesAndTraitsAndGrouping as well?
On May 10, 2010, at 11:15 AM, Mariano Martinez Peck wrote:
Hi folks. I've just discovered that PackageInfo >> classes  return a collection of classes AND traits. This is incorrect. Solutions are:
1) Rename #classes to #classesAndTraits 2) Modify #classes so that it ONLY answer classes
I would like to fix it but I am not sure the consequences of such change. Maybe Monticello doesn't take into account Traits anymore hahha
Thanks for any help you can give.
Mariano _______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
-- Best regards, Igor Stasenko AKA sig.
participants (4)
-
Igor Stasenko -
Lukas Renggli -
Mariano Martinez Peck -
Stéphane Ducasse