May 10, 2010
9:19 a.m.
Hi folks. I've just discovered that PackageInfo >> classes return a collection of classes AND traits. This is incorrect.
Why is this wrong? Collections are mostly polymorphic to traits.
Ehh, classes are mostly polymorphic to traits. Lukas
Solutions are:
1) Rename #classes to #classesAndTraits 2) Modify #classes so that it ONLY answer classes
I would like to fix it but I am not sure the consequences of such change. Maybe Monticello doesn't take into account Traits anymore hahha
Yes, all users of PackageInfo will break.
Lukas
-- Lukas Renggli www.lukas-renggli.ch
-- Lukas Renggli www.lukas-renggli.ch