[Pharo-project] I don't agree with DummyXXX
From what I understand, Dummy means something different. I have using that for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem what do you think? do you have better names? -- Mariano http://marianopeck.wordpress.com
On 2012-11-21, at 12:34, Mariano Martinez Peck <marianopeck@gmail.com> wrote:
From what I understand, Dummy means something different. I have using that for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager
it's actually more like NullUImanager :) since we have the CommandLineUIManager which is headless but interactive.
DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
I prefer them, yes.
Yes I would prefer. Stef On Nov 21, 2012, at 4:34 PM, Mariano Martinez Peck wrote:
From what I understand, Dummy means something different. I have using that for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
-- Mariano http://marianopeck.wordpress.com
participants (3)
-
Camillo Bruni -
Mariano Martinez Peck -
Stéphane Ducasse