Nov. 21, 2012
3:56 p.m.
On 2012-11-21, at 12:34, Mariano Martinez Peck <marianopeck@gmail.com> wrote:
From what I understand, Dummy means something different. I have using that for class names. More accurate names can be found. I would rename:
DummyUIManager -> HeadlessUIManager
it's actually more like NullUImanager :) since we have the CommandLineUIManager which is headless but interactive.
DummySystemProgressItem -> NullSystemProgressItem DummySoundSystem -> NullSoundSystem
what do you think? do you have better names?
I prefer them, yes.