Spec terminology: renaming some terms
Hi all, I donât read mails on pharo-dev usually, so sorry if this has been discussed before (and then pointers to the discussion would be appreciated). Last week, in Pharo-users I proposed the Spec terminology changes below. Responses were positive. I am willing to volunteer to do that next week so itâs finished before the 28th and itâs included in Pharo 4. And then I will update the documentation as well. But first I want to know if there are any objections from people on this list. I propose to rename: - ComposableModel to ComposableUI - all the protocols âprotocol-*â to âAPI-*â Other renaming-related comments are also welcome. ---> Save our in-boxes! http://emailcharter.org <--- Johan Fabry - http://pleiad.cl/~jfabry PLEIAD lab - Computer Science Department (DCC) - University of Chile
You got my vote.
On 19 Feb 2015, at 13:22, Johan Fabry <jfabry@dcc.uchile.cl> wrote:
Hi all,
I donât read mails on pharo-dev usually, so sorry if this has been discussed before (and then pointers to the discussion would be appreciated).
Last week, in Pharo-users I proposed the Spec terminology changes below. Responses were positive. I am willing to volunteer to do that next week so itâs finished before the 28th and itâs included in Pharo 4. And then I will update the documentation as well. But first I want to know if there are any objections from people on this list.
I propose to rename: - ComposableModel to ComposableUI - all the protocols âprotocol-*â to âAPI-*â
Other renaming-related comments are also welcome.
---> Save our in-boxes! http://emailcharter.org <---
Johan Fabry - http://pleiad.cl/~jfabry PLEIAD lab - Computer Science Department (DCC) - University of Chile
Thanks for this Johan. On Thu, Feb 19, 2015 at 8:37 PM, Sven Van Caekenberghe <sven@stfx.eu> wrote:
You got my vote.
On 19 Feb 2015, at 13:22, Johan Fabry <jfabry@dcc.uchile.cl> wrote:
Hi all,
I donât read mails on pharo-dev usually, so sorry if this has been discussed before (and then pointers to the discussion would be appreciated).
Last week, in Pharo-users I proposed the Spec terminology changes below. Responses were positive. I am willing to volunteer to do that next week so itâs finished before the 28th and itâs included in Pharo 4. And then I will update the documentation as well. But first I want to know if there are any objections from people on this list.
I propose to rename: - ComposableModel to ComposableUI - all the protocols âprotocol-*â to âAPI-*â
Other renaming-related comments are also welcome.
---> Save our in-boxes! http://emailcharter.org <---
Johan Fabry - http://pleiad.cl/~jfabry PLEIAD lab - Computer Science Department (DCC) - University of Chile
Ben Coman wrote
Thanks for this Johan.
+1 ----- Cheers, Sean -- View this message in context: http://forum.world.st/Spec-terminology-renaming-some-terms-tp4806486p4806516... Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.
Hi Johan For me UI does not mean anything. So may be ComposableUIModel? Or ComposableUILogic Stef Le 19/2/15 13:22, Johan Fabry a écrit :
Hi all,
I donât read mails on pharo-dev usually, so sorry if this has been discussed before (and then pointers to the discussion would be appreciated).
Last week, in Pharo-users I proposed the Spec terminology changes below. Responses were positive. I am willing to volunteer to do that next week so itâs finished before the 28th and itâs included in Pharo 4. And then I will update the documentation as well. But first I want to know if there are any objections from people on this list.
I propose to rename: - ComposableModel to ComposableUI - all the protocols âprotocol-*â to âAPI-*â
Other renaming-related comments are also welcome.
---> Save our in-boxes! http://emailcharter.org <---
Johan Fabry - http://pleiad.cl/~jfabry PLEIAD lab - Computer Science Department (DCC) - University of Chile
Well, it means User Interface ;-) The thing that got everybody confused is precisely the word Model, if we keep that the confusion will continue.
On 19 Feb 2015, at 18:11, stepharo <stepharo@free.fr> wrote:
Hi Johan
For me UI does not mean anything. So may be ComposableUIModel? Or ComposableUILogic
Stef
Le 19/2/15 13:22, Johan Fabry a écrit :
Hi all,
I donât read mails on pharo-dev usually, so sorry if this has been discussed before (and then pointers to the discussion would be appreciated).
Last week, in Pharo-users I proposed the Spec terminology changes below. Responses were positive. I am willing to volunteer to do that next week so itâs finished before the 28th and itâs included in Pharo 4. And then I will update the documentation as well. But first I want to know if there are any objections from people on this list.
I propose to rename: - ComposableModel to ComposableUI - all the protocols âprotocol-*â to âAPI-*â
Other renaming-related comments are also welcome.
---> Save our in-boxes! http://emailcharter.org <---
Johan Fabry - http://pleiad.cl/~jfabry PLEIAD lab - Computer Science Department (DCC) - University of Chile
I know :) So may be Logic because this is the logic of the application. Stef Le 19/2/15 18:16, Sven Van Caekenberghe a écrit :
Well, it means User Interface ;-)
The thing that got everybody confused is precisely the word Model, if we keep that the confusion will continue.
On 19 Feb 2015, at 18:11, stepharo <stepharo@free.fr> wrote:
Hi Johan
For me UI does not mean anything. So may be ComposableUIModel? Or ComposableUILogic
Stef
Le 19/2/15 13:22, Johan Fabry a écrit :
Hi all,
I donât read mails on pharo-dev usually, so sorry if this has been discussed before (and then pointers to the discussion would be appreciated).
Last week, in Pharo-users I proposed the Spec terminology changes below. Responses were positive. I am willing to volunteer to do that next week so itâs finished before the 28th and itâs included in Pharo 4. And then I will update the documentation as well. But first I want to know if there are any objections from people on this list.
I propose to rename: - ComposableModel to ComposableUI - all the protocols âprotocol-*â to âAPI-*â
Other renaming-related comments are also welcome.
---> Save our in-boxes! http://emailcharter.org <---
Johan Fabry - http://pleiad.cl/~jfabry PLEIAD lab - Computer Science Department (DCC) - University of Chile
The problem is that people are confused by the term Model, so they will also be confused by Logic. I want to remove the confusion and make clear that it is a user interface (and that it is composable by default) -> ComposableUI. It could also be ComposableUserInterface but we do not win anything by that name, as UI is a standard acronym + we would have to type more when subclassing it. So I prefer ComposableUI.
On Feb 19, 2015, at 14:37, stepharo <stepharo@free.fr> wrote:
I know :) So may be Logic because this is the logic of the application.
Stef Le 19/2/15 18:16, Sven Van Caekenberghe a écrit :
Well, it means User Interface ;-)
The thing that got everybody confused is precisely the word Model, if we keep that the confusion will continue.
On 19 Feb 2015, at 18:11, stepharo <stepharo@free.fr> wrote:
Hi Johan
For me UI does not mean anything. So may be ComposableUIModel? Or ComposableUILogic
Stef
Le 19/2/15 13:22, Johan Fabry a écrit :
Hi all,
I donât read mails on pharo-dev usually, so sorry if this has been discussed before (and then pointers to the discussion would be appreciated).
Last week, in Pharo-users I proposed the Spec terminology changes below. Responses were positive. I am willing to volunteer to do that next week so itâs finished before the 28th and itâs included in Pharo 4. And then I will update the documentation as well. But first I want to know if there are any objections from people on this list.
I propose to rename: - ComposableModel to ComposableUI - all the protocols âprotocol-*â to âAPI-*â
Other renaming-related comments are also welcome.
---> Save our in-boxes! http://emailcharter.org <---
Johan Fabry - http://pleiad.cl/~jfabry PLEIAD lab - Computer Science Department (DCC) - University of Chile
---> Save our in-boxes! http://emailcharter.org <--- Johan Fabry - http://pleiad.cl/~jfabry PLEIAD lab - Computer Science Department (DCC) - University of Chile
Or you can define a new standard by renaming it ComposableSpec ;) ----- Nacho Smalltalker apprentice. Buenos Aires, Argentina. -- View this message in context: http://forum.world.st/Spec-terminology-renaming-some-terms-tp4806486p4806574... Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.
2015-02-19 23:24 GMT+01:00 Johan Fabry <jfabry@dcc.uchile.cl>:
The problem is that people are confused by the term Model, so they will also be confused by Logic. I want to remove the confusion and make clear that it is a user interface (and that it is composable by default) -> ComposableUI.
It could also be ComposableUserInterface but we do not win anything by that name, as UI is a standard acronym + we would have to type more when subclassing it. So I prefer ComposableUI.
But this *is* a model, not a UI. Yes a model for the UI, but still, the real UI-View is what comes through the Spec interpreter. "UI" sounds like "the whole user interface", but Specs ComposableModels are meant as "building blocks". UI-Model -> WidgetAdapter -> Widget/View. I would prefer (in this order): 1. ComposableModel (because this is the current name) 2. ComposableWidgetModel (widget: a brick or part of an UI) 3. ComposableUIModel 4. ComposableUI I am not fully against 4., because it is the goal of spec to build reuseable UIs. For example for a Spec based "ListSelectionDialog" we can reuse the whole component, not only the model, not only the view, but the whole component with interaction between the list and other controls. But I would prefer ComposableWidgetModel, because a "Widget" (button/textfield/list) is the smallest unit of a user interface representable with Spec. nicolai
On Feb 19, 2015, at 14:37, stepharo <stepharo@free.fr> wrote:
I know :) So may be Logic because this is the logic of the application.
Stef Le 19/2/15 18:16, Sven Van Caekenberghe a écrit :
Well, it means User Interface ;-)
The thing that got everybody confused is precisely the word Model, if we keep that the confusion will continue.
On 19 Feb 2015, at 18:11, stepharo <stepharo@free.fr> wrote:
Hi Johan
For me UI does not mean anything. So may be ComposableUIModel? Or ComposableUILogic
Stef
Le 19/2/15 13:22, Johan Fabry a écrit :
Hi all,
I donât read mails on pharo-dev usually, so sorry if this has been discussed before (and then pointers to the discussion would be appreciated).
Last week, in Pharo-users I proposed the Spec terminology changes below. Responses were positive. I am willing to volunteer to do that next week so itâs finished before the 28th and itâs included in Pharo 4. And then I will update the documentation as well. But first I want to know if there are any objections from people on this list.
I propose to rename: - ComposableModel to ComposableUI - all the protocols âprotocol-*â to âAPI-*â
Other renaming-related comments are also welcome.
---> Save our in-boxes! http://emailcharter.org <---
Johan Fabry - http://pleiad.cl/~jfabry PLEIAD lab - Computer Science Department (DCC) - University of Chile
---> Save our in-boxes! http://emailcharter.org <---
Johan Fabry - http://pleiad.cl/~jfabry PLEIAD lab - Computer Science Department (DCC) - University of Chile
Well, yes, I know what it is, I know about the building block idea behind it, and I know about the reusability. However, reflecting all of this in the name, ComposableModel, makes it unclear what it is for. This is what I got as feedback of people: they did not even understand that this is what you subclass to define your UI. So apparently this is confusing and not the way to go. Using âWidgetâ in the name is not really a good idea either, because then people will think that it is for parts of an UI only, not complete UIâs. Thatâs more confusion.
On Feb 19, 2015, at 20:23, Nicolai Hess <nicolaihess@web.de> wrote:
But this *is* a model, not a UI. Yes a model for the UI, but still, the real UI-View is what comes through the Spec interpreter. "UI" sounds like "the whole user interface", but Specs ComposableModels are meant as "building blocks".
UI-Model -> WidgetAdapter -> Widget/View.
I would prefer (in this order): 1. ComposableModel (because this is the current name) 2. ComposableWidgetModel (widget: a brick or part of an UI) 3. ComposableUIModel 4. ComposableUI
I am not fully against 4., because it is the goal of spec to build reuseable UIs. For example for a Spec based "ListSelectionDialog" we can reuse the whole component, not only the model, not only the view, but the whole component with interaction between the list and other controls. But I would prefer ComposableWidgetModel, because a "Widget" (button/textfield/list) is the smallest unit of a user interface representable with Spec.
---> Save our in-boxes! http://emailcharter.org <--- Johan Fabry - http://pleiad.cl/~jfabry PLEIAD lab - Computer Science Department (DCC) - University of Chile
However, reflecting all of this in the name, ComposableModel, makes it unclear what it is for.
From "Seamless Composition and Reuse of Customizable User Interfaces with Spec" ( http://rmod.lille.inria.fr/archives/papers/Ryse13a-SCICO-Spec.pdf )
UI Element: an interactive graphical element displayed as part of the Graphical User Interface. UI Model: an object that contains the state and behavior of one or several UI elements. Widget: the union of a UI Element and its UI model. My understanding was that Element is Morphic, Model is Spec and Widget is an adapter? -- But in the end once you start using it you know what to look for (= 10 minutes after reading tutorial) does it really make that much difference? It is just a subclass.
From my point having clean and well organized protocols is more important, because you will end up interacting with those order of magnitude more, and if there is method in unexpected protocol... well then I might as well use --show all protocols--. Also whenXYChanged methods are not so nice (those have been mentioned previously).
On 20 Feb 2015, at 12:23 , Nicolai Hess <nicolaihess@web.de> wrote:
2015-02-19 23:24 GMT+01:00 Johan Fabry <jfabry@dcc.uchile.cl <mailto:jfabry@dcc.uchile.cl>>:
The problem is that people are confused by the term Model, so they will also be confused by Logic. I want to remove the confusion and make clear that it is a user interface (and that it is composable by default) -> ComposableUI.
It could also be ComposableUserInterface but we do not win anything by that name, as UI is a standard acronym + we would have to type more when subclassing it. So I prefer ComposableUI.
But this *is* a model, not a UI. Yes a model for the UI, but still, the real UI-View is what comes through the Spec interpreter. "UI" sounds like "the whole user interface", but Specs ComposableModels are meant as "building blocks".
UI-Model -> WidgetAdapter -> Widget/View.
I would prefer (in this order): 1. ComposableModel (because this is the current name) 2. ComposableWidgetModel (widget: a brick or part of an UI) 3. ComposableUIModel 4. ComposableUI
I am not fully against 4., because it is the goal of spec to build reuseable UIs. For example for a Spec based "ListSelectionDialog" we can reuse the whole component, not only the model, not only the view, but the whole component with interaction between the list and other controls. But I would prefer ComposableWidgetModel, because a "Widget" (button/textfield/list) is the smallest unit of a user interface representable with Spec.
If the goal is avoiding confusion to data model classes, why not just use Spec in place of Model? It reflects the framework name, and is fairly descriptive in that the classes are neither the actual widgets, nor the models that hold data, but a specification of how they are composed and wired together. Cheers, Henry
Henrik Sperre Johansen wrote
If the goal is avoiding confusion to data model classes...
Do we even need "Composable" in the name? This is relevant from a "where we came from" standpoint, but to a new user, maybe it can be documented without adding 10 characters to the class name... ----- Cheers, Sean -- View this message in context: http://forum.world.st/Spec-terminology-renaming-some-terms-tp4806486p4806677... Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.
On Feb 20, 2015, at 12:07, Sean P. DeNigris <sean@clipperadams.com> wrote:
Henrik Sperre Johansen wrote
If the goal is avoiding confusion to data model classes...
Do we even need "Composable" in the name? This is relevant from a "where we came from" standpoint, but to a new user, maybe it can be documented without adding 10 characters to the class nameâ¦
Sure, we could consider that ⦠do you have any concrete suggestions? ---> Save our in-boxes! http://emailcharter.org <--- Johan Fabry - http://pleiad.cl/~jfabry PLEIAD lab - Computer Science Department (DCC) - University of Chile
participants (9)
-
Ben Coman -
Henrik Johansen -
Johan Fabry -
nacho -
Nicolai Hess -
Peter Uhnák -
Sean P. DeNigris -
stepharo -
Sven Van Caekenberghe