2015-02-19 23:24 GMT+01:00 Johan Fabry <jfabry@dcc.uchile.cl>:

The problem is that people are confused by the term Model, so they will also be confused by Logic. I want to remove the confusion and make clear that it is a user interface (and that it is composable by default) -> ComposableUI.

It could also be ComposableUserInterface but we do not win anything by that name, as UI is a standard acronym + we would have to type more when subclassing it. So I prefer ComposableUI.

But this *is* a model, not a UI. Yes a model for the UI, but still, the real UI-View is what comes through the Spec interpreter.
"UI" sounds like "the whole user interface", but Specs ComposableModels are meant as "building blocks".


UI-Model -> WidgetAdapter -> Widget/View.

I would prefer (in this order):
1. ComposableModel (because this is the current name)
2. ComposableWidgetModel (widget: a brick or part of an UI)
3. ComposableUIModel
4. ComposableUI

I am not fully against 4., because it is the goal of spec to build reuseable UIs.
For example for a Spec based "ListSelectionDialog" we can reuse the whole component, not only the model, not only the view, but the
whole component with interaction between the list and other controls.
But I would prefer ComposableWidgetModel, because a "Widget" (button/textfield/list) is the smallest unit of a user interface representable with Spec.



nicolai

��

> On Feb 19, 2015, at 14:37, stepharo <stepharo@free.fr> wrote:
>
> I know :)
> So may be Logic because this is the logic of the application.
>
> Stef
> Le 19/2/15 18:16, Sven Van Caekenberghe a ��crit :
>> Well, it means User Interface ;-)
>>
>> The thing that got everybody confused is precisely the word Model, if we keep that the confusion will continue.
>>
>>> On 19 Feb 2015, at 18:11, stepharo <stepharo@free.fr> wrote:
>>>
>>> Hi Johan
>>>
>>> For me UI does not mean anything.
>>> So may be ComposableUIModel?
>>> Or ComposableUILogic
>>>
>>>
>>> Stef
>>>
>>> Le 19/2/15 13:22, Johan Fabry a ��crit :
>>>> Hi all,
>>>>
>>>> I don���t read mails on pharo-dev usually, so sorry if this has been discussed before (and then pointers to the discussion would be appreciated).
>>>>
>>>> Last week, in Pharo-users I proposed the Spec terminology changes below. Responses were positive. I am willing to volunteer to do that next week so it���s finished before the 28th and it���s included in Pharo 4. And then I will update the documentation as well. But first I want to know if there are any objections from people on this list.
>>>>
>>>> I propose to rename:
>>>> - ComposableModel to ComposableUI
>>>> - all the protocols ���protocol-*��� to ���API-*���
>>>>
>>>> Other renaming-related comments are also welcome.
>>>>
>>>> ---> Save our in-boxes! http://emailcharter.org <---
>>>>
>>>> Johan Fabry�� ��-�� ��http://pleiad.cl/~jfabry
>>>> PLEIAD lab�� -�� Computer Science Department (DCC)�� -�� University of Chile
>>>>
>>>>
>>>>
>>>
>>
>>
>
>
>



---> Save our in-boxes! http://emailcharter.org <---

Johan Fabry�� ��-�� ��http://pleiad.cl/~jfabry
PLEIAD lab�� -�� Computer Science Department (DCC)�� -�� University of Chile