Well, yes, I know what it is, I know about the building block idea behind it, and I know about the reusability. However, reflecting all of this in the name, ComposableModel, makes it unclear what it is for. This is what I got as feedback of people: they did not even understand that this is what you subclass to define your UI. So apparently this is confusing and not the way to go. Using âWidgetâ in the name is not really a good idea either, because then people will think that it is for parts of an UI only, not complete UIâs. Thatâs more confusion.
On Feb 19, 2015, at 20:23, Nicolai Hess <nicolaihess@web.de> wrote:
But this *is* a model, not a UI. Yes a model for the UI, but still, the real UI-View is what comes through the Spec interpreter. "UI" sounds like "the whole user interface", but Specs ComposableModels are meant as "building blocks".
UI-Model -> WidgetAdapter -> Widget/View.
I would prefer (in this order): 1. ComposableModel (because this is the current name) 2. ComposableWidgetModel (widget: a brick or part of an UI) 3. ComposableUIModel 4. ComposableUI
I am not fully against 4., because it is the goal of spec to build reuseable UIs. For example for a Spec based "ListSelectionDialog" we can reuse the whole component, not only the model, not only the view, but the whole component with interaction between the list and other controls. But I would prefer ComposableWidgetModel, because a "Widget" (button/textfield/list) is the smallest unit of a user interface representable with Spec.
---> Save our in-boxes! http://emailcharter.org <--- Johan Fabry - http://pleiad.cl/~jfabry PLEIAD lab - Computer Science Department (DCC) - University of Chile