April 9, 2014
12:06 p.m.
On 09.04.2014 00:51, Stephan Eggermont wrote:
That would be nice but creates problems. There is existing third party code we want to use. We can be much more precise in naming, and should not use generic names for specific implementations.
"When #totalWeight is no longer below #maximumWeight, the least recently used item of the cache is evicted (removed) to make room. â is not part of the Cache behavior, but of LRUCache.
Sorry for the noise, but cnr: âThere are only two hard problems in computer science: cache invalidation and naming things.â -- Phil Karlton