Re: [Pharo-users] Error: No factory specified
I disagree: third-party code should not use un-prefixed general names for classes as long as we live in one namespace.
That would be nice but creates problems. There is existing third party code we want to use. We can be much more precise in naming, and should not use generic names for specific implementations. "When #totalWeight is no longer below #maximumWeight, the least recently used item of the cache is evicted (removed) to make room. â is not part of the Cache behavior, but of LRUCache.
On 09 Apr 2014, at 00:51, Stephan Eggermont <stephan@stack.nl> wrote:
"When #totalWeight is no longer below #maximumWeight, the least recently used item of the cache is evicted (removed) to make room. â is not part of the Cache behavior, but of LRUCache.
Yes, you are correct: how room is made available and how it is decided which entry to remove is subclass behaviour, but the fact that the cache is limited using an abstract concept of weight is not.
On 09.04.2014 00:51, Stephan Eggermont wrote:
That would be nice but creates problems. There is existing third party code we want to use. We can be much more precise in naming, and should not use generic names for specific implementations.
"When #totalWeight is no longer below #maximumWeight, the least recently used item of the cache is evicted (removed) to make room. â is not part of the Cache behavior, but of LRUCache.
Sorry for the noise, but cnr: âThere are only two hard problems in computer science: cache invalidation and naming things.â -- Phil Karlton
participants (3)
-
Markus Fritsche -
Stephan Eggermont -
Sven Van Caekenberghe