[Bloc] buildAthensPaintOn: vs asAthensPaintOn:
hi alex why do you rename asAthensPaintOn: into buildAthensPaintOn: Stef
Because I cache it. Check BlPaint>>#asAthensPaintOn:. Yes, Cairo cache is not fast enough, I profiled on 5000 bouncing atom morphs :) On Mar 6, 2016 9:59 AM, "stepharo" <stepharo@free.fr> wrote:
hi alex
why do you rename asAthensPaintOn: into buildAthensPaintOn:
Stef
Ok why you could not cache it in asAthensPaintOn: then write a comment stating it. Stef Le 6/3/16 10:08, Aliaksei Syrel a écrit :
Because I cache it. Check BlPaint>>#asAthensPaintOn:. Yes, Cairo cache is not fast enough, I profiled on 5000 bouncing atom morphs :)
On Mar 6, 2016 9:59 AM, "stepharo" <stepharo@free.fr <mailto:stepharo@free.fr>> wrote:
hi alex
why do you rename asAthensPaintOn: into buildAthensPaintOn:
Stef
But I cache it exactly in asAthensPaintOn: of superclass. it is still not the final solution and may change or removed completely. On Mar 6, 2016 10:21 AM, "stepharo" <stepharo@free.fr> wrote:
Ok why you could not cache it in asAthensPaintOn: then write a comment stating it.
Stef
Le 6/3/16 10:08, Aliaksei Syrel a écrit :
Because I cache it. Check BlPaint>>#asAthensPaintOn:. Yes, Cairo cache is not fast enough, I profiled on 5000 bouncing atom morphs :) On Mar 6, 2016 9:59 AM, "stepharo" <stepharo@free.fr> wrote:
hi alex
why do you rename asAthensPaintOn: into buildAthensPaintOn:
Stef
participants (2)
-
Aliaksei Syrel -
stepharo