[Pharo-project] Rename DummySuperclassOfColorPickerMorph
But I don't have a better name for that. Any ideas? It has a subclass ColorPickerMorph Cheers mariano
We should remove this class. It is plain bad. For that we should replace colorPickerMorph with ColorChooser. Stef On Mar 18, 2010, at 4:11 PM, Mariano Martinez Peck wrote:
But I don't have a better name for that. Any ideas? It has a subclass ColorPickerMorph
Cheers
mariano _______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
On Thu, Mar 18, 2010 at 4:19 PM, Stéphane Ducasse <stephane.ducasse@inria.fr
wrote:
We should remove this class. It is plain bad. For that we should replace colorPickerMorph with ColorChooser.
I am not sure which is the direction here. ColorPickerMorph is from Morphic-Widgets. ColorChoose is from Polymorph. If we change ALL places of PharoCore to use ColorChooser instead of ColorPickerMorph we will be completely couple to Polymorph. I mean, I would really like to be able to load and unload Polymoprh from core without problem. So..I am not sure which is the intention here. Polymorph will be in core always ? or as something optional ? Cheers Mariano
Stef On Mar 18, 2010, at 4:11 PM, Mariano Martinez Peck wrote:
But I don't have a better name for that. Any ideas? It has a subclass ColorPickerMorph
Cheers
mariano _______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
On Mar 20, 2010, at 5:52 PM, Mariano Martinez Peck wrote:
On Thu, Mar 18, 2010 at 4:19 PM, Stéphane Ducasse <stephane.ducasse@inria.fr> wrote: We should remove this class. It is plain bad. For that we should replace colorPickerMorph with ColorChooser.
I am not sure which is the direction here. ColorPickerMorph is from Morphic-Widgets. ColorChoose is from Polymorph. If we change ALL places of PharoCore to use ColorChooser instead of ColorPickerMorph we will be completely couple to Polymorph. I mean, I would really like to be able to load and unload Polymoprh from core without problem. So..I am not sure which is the intention here.
may be the colorPicker users should not be core.
Polymorph will be in core always ? or as something optional ?
I would love to have a nice core and "polymorph" an extension but it probably means that part of polymorph should be core.
Cheers
Mariano
Stef On Mar 18, 2010, at 4:11 PM, Mariano Martinez Peck wrote:
But I don't have a better name for that. Any ideas? It has a subclass ColorPickerMorph
Cheers
mariano _______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
Try UIManager default chooseColor... That would be a potentially portable facade... Regards, Gary. On Sat, 2010-03-20 at 17:52 +0100, Mariano Martinez Peck wrote:
On Thu, Mar 18, 2010 at 4:19 PM, Stéphane Ducasse <stephane.ducasse@inria.fr> wrote: We should remove this class. It is plain bad. For that we should replace colorPickerMorph with ColorChooser.
I am not sure which is the direction here. ColorPickerMorph is from Morphic-Widgets. ColorChoose is from Polymorph. If we change ALL places of PharoCore to use ColorChooser instead of ColorPickerMorph we will be completely couple to Polymorph. I mean, I would really like to be able to load and unload Polymoprh from core without problem. So..I am not sure which is the intention here.
Polymorph will be in core always ? or as something optional ?
Cheers
Mariano
Stef
On Mar 18, 2010, at 4:11 PM, Mariano Martinez Peck wrote:
> But I don't have a better name for that. Any ideas? It has a subclass ColorPickerMorph > > Cheers > > mariano
> _______________________________________________ > Pharo-project mailing list > Pharo-project@lists.gforge.inria.fr > http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
http://code.google.com/p/pharo/issues/detail?id=2199 On Sun, Mar 21, 2010 at 12:46 AM, Gary Chambers <gazzaguru2@btinternet.com>wrote:
Try UIManager default chooseColor... That would be a potentially portable facade...
Regards, Gary.
On Sat, 2010-03-20 at 17:52 +0100, Mariano Martinez Peck wrote:
On Thu, Mar 18, 2010 at 4:19 PM, Stéphane Ducasse <stephane.ducasse@inria.fr> wrote: We should remove this class. It is plain bad. For that we should replace colorPickerMorph with ColorChooser.
I am not sure which is the direction here. ColorPickerMorph is from Morphic-Widgets. ColorChoose is from Polymorph. If we change ALL places of PharoCore to use ColorChooser instead of ColorPickerMorph we will be completely couple to Polymorph. I mean, I would really like to be able to load and unload Polymoprh from core without problem. So..I am not sure which is the intention here.
Polymorph will be in core always ? or as something optional ?
Cheers
Mariano
Stef
On Mar 18, 2010, at 4:11 PM, Mariano Martinez Peck wrote:
> But I don't have a better name for that. Any ideas? It has a subclass ColorPickerMorph > > Cheers > > mariano
> _______________________________________________ > Pharo-project mailing list > Pharo-project@lists.gforge.inria.fr >
http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr
http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
participants (3)
-
Gary Chambers -
Mariano Martinez Peck -
Stéphane Ducasse