2014-01-29 Sean P. DeNigris <sean@clipperadams.com>
Nicolai Hess wrote
And I don't like the name either. I would prefere Binding or ValueBinding.
Guys, I don't love the name either, but can we do a little better than "I don't like it". The purpose of ValueHolder's existence was to notify changes to its value. A reactive variable, from FRP, kinda-sorta does that. How does Binding = 'I will notify of changes to my value'?!
----- Cheers, Sean -- View this message in context: http://forum.world.st/Issues-12717-and-12684-tp4739761p4740024.html Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.
We don't need to argue about names, ReactiveVariable is not wrong, I just don't like it:-) I just wanted to emphase on the missing discussion. Doing this change after the Pharo3 release may be more difficult than now. Even if it is a bit late. So, I am happy we have at least both. (We should try to force the use of the new name.) (Binding or PropertyBinding is how it is called in QTs QML) Nicolai