Sept. 13, 2014
5:58 p.m.
On 13/9/14 10:54, Johan Brichau wrote:
Hi guys,
As described in this issue on the Seaside tracker [1], it appears that setting a breakpoint on a method simply sends the #break message. As #break is not an uncommon method name, the choice for this makes is a de-facto reserved method in Pharo.
Would it not be better to rename #break to #_break ? This will avoid unintended clashes. I would avoid using _break because we have halt and not _halt. Now for break we could have Halt break or something like that to remove from Object selector space.
Johan