Hi guys, As described in this issue on the Seaside tracker [1], it appears that setting a breakpoint on a method simply sends the #break message. As #break is not an uncommon method name, the choice for this makes is a de-facto reserved method in Pharo. Would it not be better to rename #break to #_break ? This will avoid unintended clashes. Johan [1] https://code.google.com/p/seaside/issues/detail?id=829
On 13/9/14 10:54, Johan Brichau wrote:
Hi guys,
As described in this issue on the Seaside tracker [1], it appears that setting a breakpoint on a method simply sends the #break message. As #break is not an uncommon method name, the choice for this makes is a de-facto reserved method in Pharo.
Would it not be better to rename #break to #_break ? This will avoid unintended clashes. I would avoid using _break because we have halt and not _halt. Now for break we could have Halt break or something like that to remove from Object selector space.
Johan
stepharo wrote:
On 13/9/14 10:54, Johan Brichau wrote:
Hi guys,
As described in this issue on the Seaside tracker [1], it appears that setting a breakpoint on a method simply sends the #break message. As #break is not an uncommon method name, the choice for this makes is a de-facto reserved method in Pharo.
How often is "break" this typed and does it need to be so concise? Now #break sounds like it breaks execution "right now", similar to "halt". If it just "sets" a brekapoint, then "setBreak" sounds more intention revealling, or even "setBreakpoint". cheers -ben
Would it not be better to rename #break to #_break ? This will avoid unintended clashes.
I would avoid using _break because we have halt and not _halt. Now for break we could have Halt break or something like that to remove from Object selector space.
Johan
Hello, #break has been removed from Pharo4 as we will move to use Refelectivity meta-links for breakpoints (meta annotation on the AST level, not source visible). On 13 Sep 2014, at 10:54, Johan Brichau <johan@inceptive.be> wrote:
Hi guys,
As described in this issue on the Seaside tracker [1], it appears that setting a breakpoint on a method simply sends the #break message. As #break is not an uncommon method name, the choice for this makes is a de-facto reserved method in Pharo.
Would it not be better to rename #break to #_break ? This will avoid unintended clashes.
Johan
participants (4)
-
Ben Coman -
Johan Brichau -
Marcus Denker -
stepharo