There are A TON of things named Morphs inside Bloc. Bloc has no choice because it wants to be 100% compatible with Morphic. That means it has to offer a 100% Morphic API . What Bloc does is rework the ugly internals of Morphic offering a better implementation and of course adds a lot of new functionality and integrates Athens. Morphic is here to stay for a long time, at least until people migrate completely to Bloc and Bloc finally decides to drop Morphic support. I dont see that happening before Pharo 8-10. On Sat, Jan 16, 2016 at 12:07 PM Esteban Lorenzano <estebanlm@gmail.com> wrote:
On 16 Jan 2016, at 09:18, Dimitris Chloupis <kilon.alios@gmail.com> wrote:
Personally I dont see the point of a rename, we got like 30% of people coming from macos that will be familiar with the name Growl, 0% that will be familiar with any other name. So you take a name that is very popular and change it to something none knows, how is that an improvement ?
What notification morph, or notification popup even means ? Is it a window ? is it a right click menu popup ?
Only the time having to port everything to the new name does not make it worth it.
+1
also, afaik, migrating to bloc will not make morphs disappear⦠they will just change its internal logic (in the examples Iâve seen, there are still things named âMorphâ⦠they are just decomposed internally⦠but I donât know).
Esteban
On Sat, Jan 16, 2016 at 10:12 AM stepharo <stepharo@free.fr> wrote:
So if you want to change (and some tools should not hardcode access to GrowlMorph) a better name would be NotifierPopup
Le 16/1/16 09:03, stepharo a écrit :
but notificationPopup is misleading because this is not a Notification (Exception).
Stef
Le 15/1/16 23:36, Ferlicot D. Cyril a écrit :
Le 15/01/2016 22:51, Mariano Martinez Peck a écrit :
I clearly would use Notification as part of the name, and not Growl. NotificationPopup?
I love this one!
-- Mariano http://marianopeck.wordpress.com