On Jan 24, 2011, at 9:36 AM, Nicolas Cellier wrote:
Sure, we got the right to change historical code.
But beware, naming actions with physical button positioncould be misleading... ... it does not take into account the logical indirection.
We could as well use intention revealing names like selectButton operateButton haloButton... .. Err, no more halo in Pharo, these names are prematurely frozen and don't take future evolutions into account.
Oh, we need some more neutral naming scheme, but for sure, something less colorfull that these childish st-80 and e toys. I suggest you use whiteButton greyButton blackButton, or maybe paleBlueButton, lightCyanButton to be more inline with an aqua theme
*no* Colors have no *meaning* in this context. I can not even tell you the three colors we have now. And not at all which is supposed to be the middle one. Colors for buttons make no sense *at all* if your buttons have no colors. Marcus -- Marcus Denker -- http://www.marcusdenker.de INRIA Lille -- Nord Europe. Team RMoD.