Re: [Pharo-project] What about a little rename in MouseEvent?
On Jan 24, 2011, at 9:36 AM, Nicolas Cellier wrote:
Sure, we got the right to change historical code.
But beware, naming actions with physical button positioncould be misleading... ... it does not take into account the logical indirection.
We could as well use intention revealing names like selectButton operateButton haloButton... .. Err, no more halo in Pharo, these names are prematurely frozen and don't take future evolutions into account.
Oh, we need some more neutral naming scheme, but for sure, something less colorfull that these childish st-80 and e toys. I suggest you use whiteButton greyButton blackButton, or maybe paleBlueButton, lightCyanButton to be more inline with an aqua theme
*no* Colors have no *meaning* in this context. I can not even tell you the three colors we have now. And not at all which is supposed to be the middle one. Colors for buttons make no sense *at all* if your buttons have no colors. Marcus -- Marcus Denker -- http://www.marcusdenker.de INRIA Lille -- Nord Europe. Team RMoD.
Don't take me wrong. I perfectly agree that colors have no meaning. They had once upon a time on the dorado, but we don't care. What I say is that there is a level of indirection between physical button and semantic buttons: (left, middle, right) -> logical buttons (whatever you call them) -> semantic buttons (operate, menu, extra) So either you keep the logical indirection, or you remove it. If you keep it, the naming is not that obvious and has to be abstract. So the colours are not a bad choice from this POV. Call it alpha, beta gamma if you will, but then you are changing things just for the sake of changing. If you remove the indirection, then you have to wonder if you don't loose something, and that was the meaning behind my post. I don't have the answer to this one, but you have to think of it. It's a bit boring to explain one's joke, sorry for that ;). Nicolas 2011/1/24 Marcus Denker <marcus.denker@inria.fr>:
On Jan 24, 2011, at 9:36 AM, Nicolas Cellier wrote:
Sure, we got the right to change historical code.
But beware, naming actions with physical button positioncould be misleading... ... it does not take into account the logical indirection.
We could as well use intention revealing names like selectButton operateButton haloButton... .. Err, no more halo in Pharo, these names are prematurely frozen and don't take future evolutions into account.
Oh, we need some more neutral naming scheme, but for sure, something less colorfull that these childish st-80 and e toys. I suggest you use whiteButton greyButton blackButton, or maybe paleBlueButton, lightCyanButton to be more inline with an aqua theme
*no* Colors have no *meaning* in this context. I can not even tell you the three colors we have now. And not at all which is supposed to be the middle one.
Colors for buttons make no sense *at all* if your buttons have no colors.
    Marcus
-- Marcus Denker  -- http://www.marcusdenker.de INRIA Lille -- Nord Europe. Team RMoD.
*no* Colors have no *meaning* in this context. I can not even tell you the three colors we have now. And not at all which is supposed to be the middle one.
+1, I don't know the colors either.
Colors for buttons make no sense *at all* if your buttons have no colors.
AFAIK, most operating systems number the mouse buttons. - The primary button is what you use to perform actions (typically left mouse button). - The secondary buttons is what you use to open context menu (typically right mouse button). - The third button is the middle button, the fourth button, ... Now I see that numbers are not that far from colors, but at least they have a logical order. I don't like #select, #menu, #extra because I does not make sense in any other context (for example games, or touch applications) than a traditional GUI. Lukas -- Lukas Renggli www.lukas-renggli.ch
Lukas Renggli wrote:
... AFAIK, most operating systems number the mouse buttons.
- The primary button is what you use to perform actions (typically left mouse button). - The secondary buttons is what you use to open context menu (typically right mouse button). - The third button is the middle button, the fourth button, ...
Now I see that numbers are not that far from colors, but at least they have a logical order. I don't like #select, #menu, #extra because I does not make sense in any other context (for example games, or touch applications) than a traditional GUI.
Agree, on one side there are the physical buttons (button 1, 2, 3 etc) and on the other hand there are the events they trigger. e.g. for right-handed people button 1 would be the primary button where for left-handed this could very well be button 3. Then again, maybe it is time to look a bit further as it looks like the near future is heading towards a world without any physical buttons where there is no need to number or name buttons at all :) http://www.geek.com/articles/gadgets/new-apple-patent-puts-a-display-on-the-... Additional gesture events: http://www.youtube.com/watch?v=JKlkte1aOOw -- View this message in context: http://forum.world.st/What-about-a-little-rename-in-MouseEvent-tp3233363p323... Sent from the Pharo Smalltalk mailing list archive at Nabble.com.
Regarding the "looking into the future" i was thinking that we will go the Smalltalk way, by reifying such new events. Instead of "reusing" plain old three button mouse events. And leave the MouseEvent for what they were originally conceived (the proposed renaming ) In this scenario a touch pad would generate a TouchPadEvent, and a multibutton mouse would generate "MultiButtonMouseEvent" Fernando On Tue, Jan 25, 2011 at 10:58 AM, Geert Claes <geert.wl.claes@gmail.com> wrote:
Lukas Renggli wrote:
... AFAIK, most operating systems number the mouse buttons.
- The primary button is what you use to perform actions (typically left mouse button). - The secondary buttons is what you use to open context menu (typically right mouse button). - The third button is the middle button, the fourth button, ...
Now I see that numbers are not that far from colors, but at least they have a logical order. I don't like #select, #menu, #extra because I does not make sense in any other context (for example games, or touch applications) than a traditional GUI.
Agree, on one side there are the physical buttons (button 1, 2, 3 etc) and on the other hand there are the  events they trigger.  e.g. for right-handed people button 1 would be the primary button where for left-handed this could very well be button 3.
Then again, maybe it is time to look a bit further as it looks like the near future is heading towards a world without any physical buttons where there is no need to number or name buttons at all :)
http://www.geek.com/articles/gadgets/new-apple-patent-puts-a-display-on-the-...
Additional gesture events: http://www.youtube.com/watch?v=JKlkte1aOOw
-- View this message in context: http://forum.world.st/What-about-a-little-rename-in-MouseEvent-tp3233363p323... Sent from the Pharo Smalltalk mailing list archive at Nabble.com.
participants (5)
-
Fernando Olivero -
Geert Claes -
Lukas Renggli -
Marcus Denker -
Nicolas Cellier