Jan. 25, 2017
10:59 a.m.
On 25 Jan 2017, at 11:55, Denis Kudriashov <dionisiydk@gmail.com> wrote:
2017-01-25 11:47 GMT+01:00 Norbert Hartl <norbert@hartl.name>: To be honest I think #isReadOnlyObject: is worse :) isXXX is a prefix for testing methods. isXXX with an argument feels even more strange. I would rather have #beReadOnly
Now there is #beReadOnlyObject and #beWritableObject. Maybe for primitive it is better to use #primReadOnlyObject:.
why the object suffix, everything is an object, right ? the simplest wording is often the best, unless there is a good reason for something else.
It also raise another question: does these primitives support mirror approach? (when it can be called with receiver as first argument?)