+1 too. Session is a bad name for a class. More than that, the people who introduced it, didn't care about: - removing unused session ivar from SmalltalkImage class - that putting #reset in Session class side, means exposing resetting mechanism to public, instead of keeping it private (and it is quite important to keep it private, because session should be reset once and only once and only in single , fully controllable place) from that perspective, i'd prefer using 'session' ivar in SmalltalkImage instead of 'current' in Session. On 12 September 2013 15:13, Esteban A. Maringolo <emaringolo@gmail.com>wrote:
+1
Very abstract names are fine when you have namespaces, otherwise I rather chose more specific names.
Regards!
Esteban A. Maringolo
2013/9/12 Torsten Bergmann <astares@gmx.de>
In Pharo 3.0 there is a new class "Session" - to represent the current smalltalk session. Using the term "Session" is very abstract.
IMHO I would rather like to see it named more specific like "ImageSession", "PharoSession" or "SmalltalkSession" before it get used too much.
Any comments? T.
-- Best regards, Igor Stasenko.