Status: Accepted Owner: Torsten....@astares.de New issue 3445 by Torsten....@astares.de: [Repackage] "SUnit" should be well structured http://code.google.com/p/pharo/issues/detail?id=3445 Pharo 1.2beta 12280: I now reorganized the SUnit package: - introduce a SUnit-Core-X category instead of SUnit-X categories - rename SUnitGUI into SUnit-UI category - SUnit-Events becomes SUnit-Core-Announcements since announcements are used - rename ivar result in TestCaseAnnouncement into testResult since this is more consistent with ivar testCase and testSelector - method comments on TestCaseAnnouncement - class comment on TestCaseAnnouncement, TestCaseEnded and TestCaseStarted - a new "SUnit-Core" package => this has to be SAVED in Monticello - a new "SUnit-UI" package => this has to be SAVED in Monticello A help package/tutorial is in preparation ... Attachments: Repackage-SUnit-Reorganize.cs 3.8 KB