[Pharo-project] Issue 3445 in pharo: [Repackage] "SUnit" should be well structured
Status: Accepted Owner: Torsten....@astares.de New issue 3445 by Torsten....@astares.de: [Repackage] "SUnit" should be well structured http://code.google.com/p/pharo/issues/detail?id=3445 Pharo 1.2beta 12280: I now reorganized the SUnit package: - introduce a SUnit-Core-X category instead of SUnit-X categories - rename SUnitGUI into SUnit-UI category - SUnit-Events becomes SUnit-Core-Announcements since announcements are used - rename ivar result in TestCaseAnnouncement into testResult since this is more consistent with ivar testCase and testSelector - method comments on TestCaseAnnouncement - class comment on TestCaseAnnouncement, TestCaseEnded and TestCaseStarted - a new "SUnit-Core" package => this has to be SAVED in Monticello - a new "SUnit-UI" package => this has to be SAVED in Monticello A help package/tutorial is in preparation ... Attachments: Repackage-SUnit-Reorganize.cs 3.8 KB
Updates: Status: Fixed Cc: stephane.ducasse marcus.denker adrian.lienhard Comment #1 on issue 3445 by Torsten....@astares.de: [Repackage] "SUnit" should be well structured http://code.google.com/p/pharo/issues/detail?id=3445 In SLICE-Issue-3445-RepackageSUnit-TorstenBergmann.1.mcz After loading the slice one should also evaluate: Smalltalk organization removeSystemCategory: 'SUnit-Events'; removeSystemCategory: 'SUnit-Extensions'; removeSystemCategory: 'SUnit-Kernel'; removeSystemCategory: 'SUnit-Utilities'; removeSystemCategory: 'SUnitGUI'; sortCategories. to remove the obsolete empty categories
Comment #2 on issue 3445 by Torsten....@astares.de: [Repackage] "SUnit" should be well structured http://code.google.com/p/pharo/issues/detail?id=3445 BTW: three tests in SUnit tests fail in the current #12280 image but this is not due to the changes in the changeset. Stef uncommented the pragma way in TestCase>>expectedFailures: "this implementation is far too slow and block the execution of tests since just for printing a test it scans all the literal of the system. So I reverted the old way of declaring expectedFailures" Looks like the tests are not adopted
Updates: Labels: Milestone-1.3 Comment #3 on issue 3445 by stephane.ducasse: [Repackage] "SUnit" should be well structured http://code.google.com/p/pharo/issues/detail?id=3445 May be for 1.3. I would like to focus on getting 1.2 stable. Then in January we start 1.3 unstable.
Comment #4 on issue 3445 by Torsten....@astares.de: [Repackage] "SUnit" should be well structured http://code.google.com/p/pharo/issues/detail?id=3445 There is nothing in the changeset that should make 1.2 unstable. However - if you want we can defer it to 1.3. The help package is in work anyway. The failing SUnit tests are fixed BTW (see http://code.google.com/p/pharo/issues/detail?id=3415)
Updates: Status: FixProposed Comment #5 on issue 3445 by marcus.d...@gmail.com: [Repackage] "SUnit" should be well structured http://code.google.com/p/pharo/issues/detail?id=3445 (No comment was entered for this change.)
participants (1)
-
pharo@googlecode.com