Dec. 6, 2009
1:36 p.m.
2009/12/5 <csrabak@bol.com.br>
I understand the motivation and the implementation, but IMNHO the name of the method should be #asSmallInteger or if you want more general #asNumber.
Why not #asBitNumber ?
Returning 1 or 0 is not the same thing as returning a bit, except if we agree on creating a class called bit where the operations on it abide to what it is expected for a bit.
my .019999...
Cédrick