I understand the motivation and the implementation, but IMNHO the name of the
method should be #asSmallInteger or if you want more general #asNumber.
Returning 1 or 0 is not the same thing as returning a bit, except if we agree on
creating a class called bit where the operations on it abide to what it is
expected for a bit.
my .019999...