Aug. 31, 2017
8:29 a.m.
2017-08-31 10:24 GMT+02:00 Denis Kudriashov <dionisiydk@gmail.com>:
Hi.
We now have very generic message names: - pin - unpin - setPinned: - isPinned
Problem that they collide with possible domain related names. For example I implemented pinning of tabs in Calypso and I found that I overrides #pin and #isPinned messages. Then I fix it with different names. Probably menus also uses pin word but without overrides
What you think about renaming pinning messages? Something like: - pinMemory
I would use pinInMemory -- Pavel
- unpinMemory - isMemoryPinned - setPinnedMemory: - pinMemoryDuring: (if we will introduce it)
I think it is easy to do now because not much code uses pinning