April 8, 2014
9:06 p.m.
We might be better off renaming Cache to WeightedCache (or NeoCache or SystemCache). The class comment in Cache seems to cover more than what Cache actually does itself. Stephan