Hey - sometimes these more philosophical conversations do amount to something. I will propose to gene changes and submit a pr - as after all, Pharo is ours and pointing someone to #downTo: or #upTo: would be very rewarding (and for Richard - #to: would remain the same so everyone wins) Tim Sent from my iPhone Sent from my iPhone
On 1 Mar 2019, at 18:30, K K Subbu <kksubbu.ml@gmail.com> wrote:
On 01/03/19 5:35 PM, Sven Van Caekenberghe wrote: I like this too. Why would this not happen ? It is just one selector more. I think the only possible issue is that #to:do: is known by the compiler, which makes it faster than any other iteration, even do: - there is always a tradeoff between readability and raw speed.
Thank you for the kind words. I am not sure if speed would be affected much by:
downTo: stop ^self to: stop by: -1
downTo: stop do: aBlock ^self to: stop by: -1 do: aBlock
In performance critical paths, one can always use to:do: with explicit steps.
Regards .. Subbu