April 21, 2018
1:35 p.m.
Oh yes!!!! On Sat, Apr 21, 2018 at 12:12 AM, Chris Cunningham <cunningham.cb@gmail.com> wrote:
A name like this would be clearer (although much more annoying):
returnAtLeast: minValue butNoMoreThan: maxValue 10 returnAtLeast: 12 butNoMoreThan: 48
Thanks, cbc
On Fri, Apr 20, 2018 at 12:51 PM, Hilaire <hilaire@drgeo.eu> wrote:
Hi,
Out of curiosity.
I always found the #min:max: confusing and lost in its expressiveness.
One should write:
10 min: 48 max: 12
to expect 12.
but logically one (at least me) may want to express it as:
10 min: 12 max: 48
Then when reading its source code, it is even more confusing:
min: aMin max: aMax ^ (self min: aMin) max: aMax
Are not the argument names inversed in their meaning, if any?
Hilaire
-- Dr. Geo http://drgeo.eu