Sounds like a bad naming to me. I don't see why withIndexDo is any better. It even contradicts the order of the arguments. And it is Proprietary to Pharo. Joachim
Am 10.03.2015 um 13:39 schrieb Sanjay Minni <sm@planage.com>:
Yes usually I have to open the code and see, use intuition or write a sample code to find out incidentally here I also have to figure out which is the current and which is the deprecated version ... well thats it
sanjay
--- Sanjay Minni +91-9900-902902 http://in.linkedin.com/in/sanjayminni
On Tue, Mar 10, 2015 at 5:57 PM, Thierry Goubier [via Smalltalk] <[hidden email]> wrote: And one has to guess that elementAndIndexBlock means
[:each :i | ... ] ? (and of course not [:i :each | ... ] )
I'm allways looking for senders with that type of code ;) arguments to blocks are usually not documented.
Thierry
2015-03-10 13:27 GMT+01:00 Peter Uhnák <[hidden email]>:
On Tue, Mar 10, 2015 at 1:23 PM, Joachim Tuchel <[hidden email]> wrote: #doWithIndex: ?
doWithIndex: elementAndIndexBlock "Use the new version with consistent naming" ^ self withIndexDo: elementAndIndexBlock
If you reply to this email, your message will be added to the discussion below: http://forum.world.st/when-iterating-over-a-collection-how-to-determine-the-... To unsubscribe from when iterating over a collection how to determine the current objects index, click here. NAML
--- Regards, Sanjay
View this message in context: Re: when iterating over a collection how to determine the current objects index Sent from the Pharo Smalltalk Users mailing list archive at Nabble.com.