Le 25/3/15 09:32, Sven Van Caekenberghe a écrit :
OK, I get your point now, #read and #read: are a better combination than #get and #read:
About #++ and friends, yes I think they are so uncommon that they do not warrant a special selector, what is the point ?
do not let creep in bad ideas! I can tell you from a dyslexic point of view i++ ++i and all cryptic things that makes a programmer feels like a real men is not fun. Let us use them carefully not as "look mum I can do it" Stef
On 25 Mar 2015, at 09:12, stepharo <stepharo@free.fr> wrote:
Stef,
Like Denis said, there is no #next: in Xtreams, AFIACT. Yes but this is the same we should get read and read: and not get and read: This is my point. There are
XTReadStream>>#get "Read an object from self. If there aren't any elements left in the stream, the Incomplete exception is raised."
and
XTReadStream>>#read: anInteger "Read anInteger's worth of elements from self and return them in a collection. If full anInteger number of elements cannot be read from the source, the Incomplete exception is raised."
Like I said, these selector names were chosen to prevent confusion, on purpose. I think that is good. I also think that a lot of though went into the design. I personally think that get and read: are bad and irregular.
XTReadStream>>#read "Read an object from self. If there aren't any elements left in the stream, the Incomplete exception is raised."
XTReadStream>>#read: anInteger "Read anInteger's worth of elements from self and return them in a collection. If full anInteger number of elements cannot be read from the source, the Incomplete exception is raised."
funny how the comments are good. No need to change them. This is a sign.