On 19 Jan 2018, at 02:11, Ben Coman <btc@openInWorld.com> wrote:
On 18 January 2018 at 14:33, Alistair Grant <akgrant0710@gmail.com> wrote:
Hi Hernán,
On 18 January 2018 at 05:41, Hernán Morales Durand <hernan.morales@gmail.com> wrote:
Note that in R you can set the current working directory with setwd() and this is very common in R scripts.
I like the idea around #imageDirectory and #vmStartupDirectory or just #vmDirectory. And maybe renaming #workingDirectory to #userWorkingDirectory would be more clear? Assuming 1 image = 1 user?
In Pharo 7:
FileLocator workingDirectory = C getcwd() # same as R and most languages FileLocator imageDirectory = the directory where the image is located FileLocator vmDirectory = the directory where the vm is located
I like the distinction of having all three.
yes⦠but I would like an idiom to make declarations easier. for example, you made './somethingâ asFileReference â> this is a cwd path '{image}/somethingâ asFileReference â> image path etc. because right now I have to do: FileLocator imageDirectory / âsomething' and it annoys me a bit (not that I cannot live with it, but⦠) ;) Esteban
cheers -ben