On Mon, Sep 09, 2019 at 05:46:48PM +1200, Richard O'Keefe wrote:
(3) Oddly enough, the reason that #collect:thenDo: exists in my library is that I copied it from Squeak, at a time when it had the same definition as Pharo and ST/X. Had I known of the change in Squeak I would have bitterly opposed it. The comment in the current Squeak code, that it is for readability, is 100% the reverse of the truth. Using the version with parentheses is WAY clearer than using the portmanteau method. Sigh. I see they broke #collect:thenSelect: in the same way.
In Squeak, collect:thenDo: is implemented only in Collection. The method stamp is dgd 9/13/2004 23:42, which hardly qualifies as a recent change. And the method stamp for collect:thenSelect: is sma 5/12/2000. Dave