Aug. 24, 2017
7:05 a.m.
On August 23, 2017 10:09:02 PM GMT+02:00, Stephane Ducasse <stepharo.self@gmail.com> wrote:
On Wed, Aug 23, 2017 at 9:20 PM, Herby VojÄÃk <herby@mailbox.sk> wrote:
Maybe in general sumWithFoo: => addSelfToFoo: to make clues clearer.
I see now it should be more addSelfWithFoo: or sumSelfWithFoo: because we do not modify the argument.
I argue you should preserve original order of operands, otherwise there's a confusion that dd is only usable wjen you want to switch them. So with xWithY: form, it should addFooWithSelf: / sumFooWithSelf:. Herby
Stef