April 8, 2014
10:13 p.m.
On 08 Apr 2014, at 23:06, Stephan Eggermont <stephan@stack.nl> wrote:
We might be better off renaming Cache to WeightedCache (or NeoCache or SystemCache). The class comment in Cache seems to cover more than what Cache actually does itself.
Stephan
I disagree: third-party code should not use un-prefixed general names for classes as long as we live in one namespace. I don't understand the remark about Cache being more than what a cache should be: unless it is limited in some way, which any cache should be, you could just as well use a Dictionary. The same argument can be made about the factory concept. Sven