Oct. 6, 2011
7:21 p.m.
On 06 Oct 2011, at 16:58, Levente Uzonyi wrote:
Here's a version optimized for readibility & loc:
Array streamContents: [ :primeStream | | sieve | sieve := Array new: 100 withAll: true. 2 to: sieve size do: [ :each | (sieve at: each) ifTrue: [ primeStream nextPut: each. each * each to: sieve size by: each do: [ :eachMultiple | sieve at: eachMultiple put: false ] ] ] ].
That is indeed a cooler version. Thanks for the feedback, Levente ! Sven