[Pharo-project] Issue 3592 in pharo: MenuMorph uses action: and selector: to mean the same thing
Status: New Owner: ---- New issue 3592 by sean.p.d...@gmail.com: MenuMorph uses action: and selector: to mean the same thing http://code.google.com/p/pharo/issues/detail?id=3592 e.g. MenuMorph #add:target:action: and #add:target:selector: do the same thing and should be merged. Any preference? I think action is more intention revealing How about #add:sending:to:, which from the API user's perspective would look like: menu add: 'New instance creation method' sending: #addInstanceCreationMethod to: self. Sean
Updates: Status: Accepted Comment #1 on issue 3592 by stephane...@gmail.com: MenuMorph uses action: and selector: to mean the same thing http://code.google.com/p/pharo/issues/detail?id=3592 Reducing duplication is always good. Now action: is different from selector: to me in the sense that selector: #symbol and action: could be a block. But in any case it would be good to clean it.
participants (1)
-
pharoï¼ googlecode.com