aCollection ifNotEmpty: [ ... do: [ ... ] ]
July 20, 2015
10:01 a.m.
Just curious... In AbstractTool>>renamePackages: what is gained from using... aCollection ifNotEmpty: [ ... do: [ ... ] Wouldn't "aCollection do: [ ... ]" be more concise for the same behaviour ? cheers -ben
July 20, 2015
10:31 a.m.
On 20 Jul 2015, at 12:01, Ben Coman <btc@openinworld.com> wrote:
Just curious...
In AbstractTool>>renamePackages: what is gained from using... aCollection ifNotEmpty: [ ... do: [ ... ]
Wouldn't "aCollection do: [ ... ]" be more concise for the same behaviour ?
Yes! I guess that there used to be a ifEmpty: branch that got removed and the method not cleaned up. or maybe itâs just wrong⦠You can submit a fix. Marcus
4029
Age (days ago)
4029
Last active (days ago)
1 comments
2 participants
participants (2)
-
Ben Coman -
Marcus Denker