[Pharo-project] a question about reef naming conventions
Hi, I'm having some doubts about how to call some methods for Reef. To be precise, I'm not sure about the naming og the method extensions I'm adding. For instance, I have an extension for Object, the method #asView, and some others in BlockClosure, #asCallback, asCallbackOn:, etc. So... I want to ask which naming convention is better. 1) Just let the methods like now? 2) adding a prefix, like reView, reCallback, etc.? 3) adding a full name prefix, asReefView, asReefCallback, etc.? What do you think? Cheers, Esteban
I think the third option is clearer than the others. Best Regards On Wed, Nov 3, 2010 at 7:52 PM, Esteban Lorenzano <estebanlm@gmail.com>wrote:
Hi, I'm having some doubts about how to call some methods for Reef. To be precise, I'm not sure about the naming og the method extensions I'm adding. For instance, I have an extension for Object, the method #asView, and some others in BlockClosure, #asCallback, asCallbackOn:, etc.
So... I want to ask which naming convention is better.
1) Just let the methods like now? 2) adding a prefix, like reView, reCallback, etc.? 3) adding a full name prefix, asReefView, asReefCallback, etc.?
What do you think?
Cheers, Esteban
On Thu, 04 Nov 2010 00:01:24 +0100, Diogenes Moreira <diogenes.moreira@gmail.com> wrote:
I think the third option is clearer than the others.
I agree, but I'd use a "real" prefix, exactly the same characters at the beginning, every time. So that would become: reefAsView, reefAsCallback. In my own code, I prefix selectors sometimes and always as real prefixes. But I would use an abbreviation for the project/"namespace" prefix instead of something that could be a word, so that the prefix stands out more. So that might become: rfAsView, rfAsCallback. Cheers, Peter
Best Regards
On Wed, Nov 3, 2010 at 7:52 PM, Esteban Lorenzano <estebanlm@gmail.com> wrote:
Hi, I'm having some doubts about how to call some methods for Reef. To be precise, I'm not sure about the naming og the method extensions I'm adding. For instance, I have an extension for Object, the method #asView, and some others in BlockClosure, #asCallback, asCallbackOn:, etc.
So... I want to ask which naming convention is better.
1) Just let the methods like now? 2) adding a prefix, like reView, reCallback, etc.? 3) adding a full name prefix, asReefView, asReefCallback, etc.?
What do you think?
Cheers, Esteban
-- Peter van Rooijen Nijlring 83 5152 VJ Drunen m: 06-2854 2048
participants (3)
-
Diogenes Moreira -
Esteban Lorenzano -
Peter van Rooijen