Em 10/01/2010 13:04, Mariano Martinez Peck < marianopeck@gmail.com > escreveu:
On Sun, Jan 10, 2010 at 3:38 PM, Michael Roberts <mike@mjr104.co.uk> wrote:
2010/1/10 Mariano Martinez Peck <marianopeck@gmail.com>:
[snipped]
and you can change the suffix as well, but personally i would not use the date in the image name.
For the date you refer to year, month and number of version inside the month ?
yes I think it is too complicated a version scheme. The dev tag is also synonymous with Pharo. so if your Pharo image is currently Pharo1.0-10505-rc1dev10.01.1 I would call it Pharo-1.0-10505-rc1. This is the same scheme that the core image uses, and Pharo 1.1 will have this behaviour already using #imageVersionString since it is in 1.1.
That's cool. I evaluate: SystemVersion current version: 'Pharo-1.0-10505-rc1' And seems to be almost what I want. It would be cool (maybe not for 1.0, but for 1.1) if we can see not only the version of Pharo, but also opf the pharoCore...So, SystemVersion could understand: coreVersion: and version: Then in System -> About, if I am in a core image I would see:
PharoCore1.0rc1 Latest update: #10505
OK.
And if I am in Pharo I would see Pharo1.0-10505-rc1dev10.01.1
Isn't this ^^^^^ completely redundant with:
PharoCore1.0rc1 Latest update: #10505 <<<<<<<<<--- this?
-- Cesar Rabak