Okay, I'm mostly through the refactoring. It is sooo much cleaner out of object. Many deprecated methods!! Here are a few points and questions... * Under protest :) I'm keeping the Object API, which forwards to Halt. * I was slightly liberated to find that halt behavior is not part of the ANSI standard * Halt onCount: - this is a weird one - It's currently global. Should it be per call, possibly with a (resumable?) error if called elsewhere? In other words, if I put in a Halt countOn: 3, and there is another #countOn: in the image that gets called and decrements the global count, it seems that this will give me confusing and hard to track down results. I guess maybe we can't pinpoint it to the exact call, but at least to the calling context. - The name is misleading. I thought of a few (Halt onPassNumber: 3, Halt onIterationNumber: 3, Halt onCallNumber: 3). Any suggestions while we're breaking compatibility, lol? - is there a lint check that says haltOnCount: and maybe haltOnce? - per object/method/process/exact call? * Is anybody using Object>>toggleHaltOnce? I'm toying with removing it as there are no senders in the image, and there are accessors and a testing method Sean -- View this message in context: http://forum.world.st/Halt-tp3774723p3776539.html Sent from the Pharo Smalltalk mailing list archive at Nabble.com.