alain you should pay attention that you shoudl deprecate the method. People should be able to load their code in pharo On Jun 5, 2008, at 1:52 PM, Alain Plantec wrote:
Hi all, I'm cleaning some methods which contain 'AsMorph'. for example, Browser>>openAsMorphMessageEditing: is send only in Browser>>openMessageEditString: which only returns openAsMorphMessageEditing: result. so, I copy code from Browser>>openAsMorphMessageEditing: to Browser>>openMessageEditString: and remove Browser>>openAsMorphMessageEditing:. I guess this is ok. But now I'm continuing by chasing all methods with 'InMorphic' in their name. As an example, there is Morph>>embeddedInMorphicWindowLabeled:. the question is, do I make the asumption that morphic is the only way or the default (then Morph>>embeddedInMorphicWindowLabeled: can be renamed as Morph>>embeddedInWindowLabeled:) or do I let it as is ?
the same would be applied to openInMorphic (->open), inspectModelInMorphic (->inspectModel), inspectInMorphic: (-
inspect:), inspectInMorphic (->removed because no sender),
thanks
for now I'm not sure that I would focus on that. I would clean really the ugly part and etoy. stef
alain
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project