To continue the discussion on this topic (stemming from issue 11635) Iâm starting a new thread. Please share your thoughts. Form the other thread:
Personally I'm for more intention revealing selectors; I quite like #shuffled and #shuffleInPlace. If we can agree on a different naming scheme we should then apply it to other methods aswell of course (e.g. #sorted, #sortInPlace).
My proposition is to keep the selectors named #â¦d (#shuffled, #sorted, etc.), which operate on a copy, and rename the others (#shuffle, #sort, etcâ¦) to #â¦InPlace (#shuffleInPlace, #sortInPlace, etc.). The rational behind this is that (to my mind) the current scheme is not intention revealing (e.g. #shuffle vs. #shuffled). Which is especially problematic for newcomers. Max