Oct. 5, 2015
1:09 p.m.
On 05 Oct 2015, at 14:58, Thierry Goubier <thierry.goubier@gmail.com> wrote:
2015-10-05 14:53 GMT+02:00 Damien Cassou <damien.cassou@inria.fr <mailto:damien.cassou@inria.fr>>: The comment of the following method seems to be more an explanation of the implementation than of the expected behavior. Should we change that to something like: "Return an instance of RBBlockNode representing the receiver's AST."
Which would completely hide the reason for going backward one step in the bytecode.
I'd vote for adding to the current comment.
Yes, add to it. the implementation comment is important: âWhy the heck -1â... Marcus