Would it be possible to instead have a #haltIf object to which you can send additional conditions? E.g. self haltIf insideTest self haltIf outsideTest Makes it (imho) a bit more readable, adds just a single method to Object, and allows for more potential extensions... self haltIf nil. self haltIf count: 3. etc? Peter On Wed, Apr 4, 2018 at 8:36 AM, Christophe Demarey < christophe.demarey@inria.fr> wrote:
Le 4 avr. 2018 à 04:34, Sean P. DeNigris <sean@clipperadams.com> a écrit :
demarey wrote
What about haltIfTestExecutionEnvironment and haltIfDefaultExecutionEnvironment ?
I thought the names were okay. What did you think was unclear about them?
At a first look #haltInsideTest and #haltOutsideTest do not tell me that they are conditional breakpoints. maybe just add a if would solve that: #haltIfInsideTest #haltIfOutsideTest