Then #readStreamXYZ would do the job. Depending on how you write the methods, both you and the collection have a say, or you can also have complete control. ________________________________ From: pharo-project-bounces@lists.gforge.inria.fr [mailto:pharo-project-bounces@lists.gforge.inria.fr] On Behalf Of Michael van der Gulik Sent: Thursday, September 03, 2009 4:33 PM To: Pharo-project@lists.gforge.inria.fr Subject: Re: [Pharo-project] [ANN] On Fri, Sep 4, 2009 at 3:21 AM, Stéphane Ducasse <stephane.ducasse@inria.fr<mailto:stephane.ducasse@inria.fr>> wrote: - Issue 1144: Many occurrences of "ReadStream on: aCollection" which can be replaced with "aCollection readStream" For what it's worth, I prefer the style of "ReadStream on: xxx". I prefer to choose the stream class rather than let the collection choose it for me. Gulik. -- http://gulik.pbwiki.com/