Dec. 16, 2010
10:09 a.m.
Hi peter
But since you ask for our opinion I really dont like some of the methods' names specially the ones using "the" as prefix.
what is the alternative? class?
#itsClass #parentClass (suggested by Tudor)
Create a new poor mans's selector namespace and call it #ringClass (or #RINGclass or #ring_class or #RING_class to highlight the namespace part of the selector more).
it does not work because we want to have also this method to return the runtime class.
This way you retain the advantage of the familiarity of an old name (#class) and avoid clashes, for the price of a some extra keyboarding.
Stef